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1: What Is MIB Dump 
Manager 

NMS Shops Collect Dumps 
Any NMS shop whether it is a product shop or a consulting shop is 
going to collect SNMP MIB Dumps. It is unavoidable.   
 
Dumps are collected to load into a MIB Simulator and test NMS 
software. Dumps are collected to plan out new features. Dumps are 
collected when customers have bugs. 

How To Make Sense Of It All 
Dumps contain a lot of information, most of which is not relevant to a 
particular problem being solved. MDM allows you to define the tables 
and variables (Features) that are important to you. MDM then scans all 
of your dumps and catalogs which dumps contain which features. 
 
MDM allows you to attach Notes to dumps and dump folders to track 
things like which customer this dump is for or which trouble ticket 
number this dump is related to. 
 
Use MDM in conjunction with Network Ferret MIB Analysis, to have a 
powerful toolset to quickly investigate issues.  

What Questions Can MDM Answer? 
• What Features (tables/variables) are included in this dump? 
• Which dumps contain a selected set of features? 
• How do the features compare between multiple dumps? 
• Which SNMP simulator projects contains this dump? 
• Show which dumps are in a simulator project. 
• Which dumps match for this sysOID, sysDescr, file name or 

notes? 
• Scan for a random OID and show which dumps contain it. 
• How much file space are the dumps taking? 
• A dump was just received from a customer, quickly scan it and 

show what Features (tables/variables) it has. 
 



 

 Network Ferret™ – MIB Dump Manager v18 2 

2: Quick Start 

Installation 
Unzip the distribution and follow the instructions in the readme. It is 
necessary to know where the machine’s Java installation is. 

Sample Database 
The distribution comes with a subfolder called dumps which contains a 
few MIB Dumps and a pre-scanned database. 
 
The database was scanned using the nfMIBDumpManager.def file 
located in the root directory of the distribution. 

Start MDM 
Start MDM and do File->Set Root Directory… to the dumps directory in 
the distribution.  MDM consists of two panes. The left pane shows the 
folder hierarchy of dumps that were scanned. The right pane shows 
the features defined in nfMIBDumpManager.def. 
 
Select the first Brocade dump on the left. 
 

 



 

 Network Ferret™ – MIB Dump Manager v18 3 

See The Features In The Dump 
The features pane on the right will highlight in green all of the features 
found in the selected dump. 
 
For example, the dump has the IPv6 table but not the older IPv4 table 
nor the newer IPv6 table in the .55 branch. 
 
It can also be seen that the device has the VRRP feature but not the 
HSRP feature. 
 

Which Dumps Have The IPv6 table 
Hit the Clear Selection/Filter button at the top of the left pane. 
 
Right-click on the IPAddressv6 row in the Features pane on the right 
and select Which Dumps Have This Feature. 
 

 
 
MDM shows that three of the four dumps contain the IPv6 table. 

How Do Two or More Dumps Compare 
Hit the Clear Selection/Filter button at the top of the left pane. 
 
Use CTRL-click to select the two Brocade dumps. Right-click and 
choose Compare features between dumps. 
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The Feature Comparison tab will activate on the right. This will only 
show features that at least one dump has. 
 
The example, shows that one Brocade device has the VRRP and LAG 
features while the other does not. 
 
This is very useful in a situation where a client sends multiple dumps of 
a network and says, “You are not hooking up everything correctly”. A 
quick comparison of the features will show which devices have the 
switch data and the investigation can start there. 

View The Dump Data 
Right-click on a dump and select Open File in MIB Analysis.  This will 
open the Network Ferret – MIB Analysis Tool.  This is essentially a MIB 
Browser on a dump file rather than a running device or simulation. 
 
Of course, MIBs will need to be scanned first or the AMT MIB database 
can be downloaded. 
 

Do The First Scan 
Those are the four main features of MDM.  Now you are ready to do 
your first scan. All of the other features will be discussed later. 
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3: Scanning 

nfMIBDumpManager.def 
This is an XML formatted file. Two small parts of this file define what 
files to scan and what files NOT to scan. The file is in the root directory 
of the distribution. 
 
Edit the file in any text editor and scroll to the bottom. You can also 
select File->Set External Editor and open the file directly from MDM. 
 
One section defines the file extensions to scan. The other section 
defines folders and files to ignore. 
 

<Extensions> 
 <Extension name=".xml">  </Extension> 
 <Extension name=".txt">  </Extension> 
 <Extension name=".wlk">  </Extension> 
</Extensions> 
 
<Ignore> 
 <Directory name="OLD">   </Directory> 
 <Directory name="mibs">   </Directory> 
 <FileName contains="copy">  </FileName> 
</Ignore> 
 

The rest of the document will be explained later.   
 
The .def file included in the distribution is the actual .def file used at 
AMT. Network Ferret is a topology discovery engine and that is 
reflected in the features that are defined. 
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Set The Default nfMIBDumpManager.def File 
Select File->Set Default Definition File and select the file in the root 
of the distribution. This will be remembered between runs of MDM. 
 
The default file can be located anywhere. Any directory that is scanned 
can also have its own version of this file for purposes of scanning 
features different from the default. 
 

Set The Root Directory 
The root directory is where three of the four scan options will work 
from. 
 
Select File->Set Root Directory and choose the directory to be 
scanned. If a database already exists in that directory, it will be loaded. 
 
Scanning will recursively traverse the directory hierarchy. 
 

Scan Everything 
Select File->Scan All. The Scanner window open and scanning will 
commence. 
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The scanner window puts out a lot of information. Errors will be in red.  
Warnings will be in yellow. Progress/Category will be in cyan. The final 
line will, hopefully, be in green. Use the Find Next Line With Color 
button to quickly move through these lines. 
 
Use the Find, Find Next and Count All widgets to do standard text 
searching. 

Save The Database 
If satisfied with the scan, hit the Save Database button and close the 
Scanner window. The database file, nfMIBDumpManager.dat, will be 
placed in the Root Directory that was scanned. 
 
Note that there is nothing in the database that was not scanned from a 
dump file. So if the database is corrupted, simply delete the file and 
rescan. 
 
The database file can be moved elsewhere to be browsed. Scans will 
fail since the database is no longer located with the actual dumps. 
Notes will function as long as the machine browsing the database has 
access to the hierarchy containing the dumps. 

Scan For New Dumps 
Select File->Scan For New. The Scanner window open and scanning 
will commence. 
 
The scanner will look for new files only. It is NOT looking for changes 
in existing files nor is it looking for files that are no longer there. 
 
The Scan Window will display the results. If Save Database is chosen, 
the hierarchy in the main window will highlight the new files. 

Scan For A Random OID 
Select File->Scan Random OID. Enter the OID to scan for. The 
Scanner window open and scanning will commence. 
 
Use this option when you quickly want to see which dumps have a 
Feature (table/variable) that you have not defined in the .def XML file. 

 
The Scan Window will display the results. There is no Save option. The 
hierarchy in the main window will highlight any dumps that contain the 
OID. 
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Scan A Random File 
Select File->Scan Random File. Select the file to scan.This file can be 
anywhere in the system. 
 
The Scanner Window will open and the file will be scanned. There is 
no option to update the database. The Scanner Window will show the 
Features (tables/variables) that were found in the file. 
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4: Definition File 
nfMIBDumpManager.def is an XML format file that defines what MDM 
will scan for. It has 6 sections. These sections MUST stay in order in 
the file. 
 
The file in the distribution is the actual file used at AMT. Network Ferret 
is a topology discovery engine so you will probably need to edit this file 
heavily to define the Features (tables/variables) that are important to 
your application. 

Section 1 - Substitutions 
The substitutions section defines human readable names to replace 
OID strings. It is important to put the dot (.) on the end of the name and 
the OID. 
 

<Substitutions> 
 <Substitution name="mib2."   oid="1.3.6.1.2.1.">  </Substitution> 
 <Substitution name="exp."   oid="1.3.6.1.3.">  </Substitution> 
 <Substitution name="private."  oid="1.3.6.1.4.1.">  </Substitution> 
 <Substitution name="mpls."   oid="1.3.6.1.2.1.10.166."> </Substitution> 
</Substitutions> 

 
Substitutions are used to make Feature definitions easier to read. 
 

 <Feature name="sysServices"   oid="mib2.1.7.0"> </Feature> 



 

 Network Ferret™ – MIB Dump Manager v18 10 

Section 2 - Features 
Features represent MIB tables or individual variables that are important 
to your application. This is what is looked for during scanning. 
 

<Feature name="Switch"> 
 <Feature name="Address"   oid="mib2.17.1.1">  </Feature> 
 <Feature name="Ports"   oid="mib2.17.1.4.1">  </Feature> 
 <Feature name="Forwarding DB"  oid="mib2.17.4.3.1">  </Feature> 
 <Feature name="Forwarding DB New" oid="mib2.17.7.1.2.2.1"> </Feature> 
 <Feature name="Spanning Tree"> 
  <Feature name="STD"  oid="mib2.17.2.15.1">  </Feature> 
  <Feature name="Huawei"  oid="Huawei.5.25.42.4.1.20"> </Feature> 
 </Feature> 
</Feature> 

 
Logical Features can be created to better organize things. For 
example, Switch and Spanning Tree are logical features above. 
Essentially, folders of Features. 
 
A Logical Feature is permitted to have an OID as well. See the LLDPv1 
and LLDPv2 sections of the definition file shipped with the distribution. 
 
Note that Huawei above is an example of a Vendor substitution which 
is explained below. 
 
The top level features will be sorted alphabetically in the MDM window. 
All other features will appear in the same order as defined in the file. 
 
The graphic below shows how the Feature definition appears in the 
MDM window. 
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Section 3 - Vendors 
This section defines a mapping between a vendor’s name and their 
number in the private branch of the MIB tree. 
 
These names can be used in the Features definition section above. 
These names will also be used in the Vendor column in the left pane of 
MDM. 
 

 
 
Below is a sample from the file in the distribution. 
 

<Vendors> 
 <Vendor name="Brocade"   oid="1588">  </Vendor> 
 <Vendor name="Brocade"   oid="1991">  </Vendor> 
 <Vendor name="Cisco"   oid="9">  </Vendor> 
 <Vendor name="Dell"   oid="674">  </Vendor> 
 <Vendor name="DLink"   oid="171">  </Vendor> 
 <Vendor name="Ericsson"  oid="193">  </Vendor> 
 <Vendor name="Extreme"  oid="1916">  </Vendor> 
 <Vendor name="Huawei"   oid="2011">  </Vendor> 
 <Vendor name="Juniper"   oid="2636">  </Vendor> 
 <Vendor name="Juniper"  oid="4874">  </Vendor> 
 <Vendor name="NEC"   oid="119">  </Vendor> 
 <Vendor name="QTech"   oid="27514"> </Vendor> 
 <Vendor name="SNMPResearch" oid="99">  </Vendor> 
 <Vendor name="Timetra"   oid="6527">  </Vendor> 
 <Vendor name="Viptela"   oid="41916"> </Vendor> 
 <Vendor name="VMWare"   oid="6876">  </Vendor> 
</Vendors> 

 
 
We consciously did NOT include a line for the many thousands of 
vendor numbers defined. 
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Section 4 – MIB Simulator 
The purpose of this section is to allow MDM to integrate with MIB 
Simulators and help to generate config/project file definitions. 
 
This capability will evolve as we get more experience with other 
simulators. AMT uses iReasoning so MDM ships with a plugin for that 
product. 
 

<!-- Plugin to work with MIB simulators --> 
<!-- Currently, the only possible names to use are ireasoning or none --> 
<Simulator name="none" root="C:\Users\rkostes\Documents\ireasoning">
 <ireasoning> 
   <!-- These are all relative to the root --> 
  <projectsRoot       name="projects">  </projectsRoot>  
  <defaultConfigFile  name="stdDev_config.xml"> </defaultConfigFile>  
  <defaultTrapFile    name="trap.dat">  </defaultTrapFile>  
 </ireasoning> 
</Simulator> 

 
If you use iReasoning, change Simulator name= to ireasoning and 
modify the various folders and files. 
 
See the Simulator chapter for a description of what you can do in MDM 
with iReasoning. 
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Section 5 – Extensions 
The file extensions to be scanned. Network Ferret generates both txt 
and XML files for each device dump created at a customer site. 
 
The XML files are more verbose so if duplicate files are found and one 
has a .xml extension, the other file will be scanned. Also, the text files 
are easier for humans to read if one is opened. 
 

<Extensions> 
 <Extension name=".xml">  </Extension> 
 <Extension name=".txt">  </Extension> 
 <Extension name=".wlk">  </Extension> 
</Extensions> 

 
MDM has a File Size column in the left pane. Each folder adds up the 
files contained in it. But keep in mind that this may not be an accurate 
account of the space being taken on disk. Remember that if both a txt 
and XML version of a file exist, the text version will be scanned and the 
XML version will not be in the database and thus not counted. 

XML Files 
MDM expects XML files to use the tags used by iReasoning.  If there 
are other XML formats for dumps, please send us a sample and we will 
incorporate it. 
 
Technically, MDM is not building the XML object tree when scanning.  
It is scanning the file looking for three things: 
 

<?xml – on the first line of the file 
 

 Lines with oid=”someOid” 
 

<![CDATA[value ]]> when trying to extract the 
sysDescriptor and sysOID.  If the character data is 
split across lines, it will not be extracted. 
 
Since MIB Analysis needs to extract the values as well as the OIDs, it 
will build the XML object tree when it loads a dump to be analyzed.  It 
has more specific requirements for the XML format.  See that 
documentation. 
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Section 6 – Ignore 
Directories and files to be ignored.  Case does not matter. 
 

<Ignore> 
 <Directory name="OLD">   </Directory> 
 <Directory name="mibs">  </Directory> 
 <!-- <FileName contains="" or startsWith="" or endsWith=""> </FileName> --> 
 <FileName contains="copy">  </FileName> 
</Ignore> 
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5: Filters 
MDM provides many filters that will highlight sections of the dump 
hierarchy. 

Features Filter 
This is the most powerful filter in MDM. It is set by selecting Features 
in the right pane (CTRL-click to multiselect), right-clicking and selecting 
  
 Which dumps have this feature 
  or 
 Which dumps DO NOT have this feature 
 
The dump hierarchy on the left will highlight all of the dumps that 
contain the feature(s). 
 
Selecting a Feature Folder will include all of the features in that folder 
and there is an implicit AND operation. 

Containing Filters 
There are four filters that will do a text search. These are found in the 
main window menu under Filter. They search against: 
 
The dump file name 
The sysDescriptor 
The sysOID 
Notes – this search is case sensitive 
 
Any dumps passing the search will be highlighted. 

Notes Filter 
This filter will highlight any dumps/folders that have Notes defined. It 
does not matter what the Note contains. This Filter is found in the main 
window menu under Filter. 

No Translated Vendor 
This filter will highlight any dumps that do not have a Vendor 
translation in the definition file. This Filter is found in the main window 
menu under Filter. 
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6: Dump Actions 
The dump hierarchy in the left pane of MDM reflects the file system 
where the dumps were scanned. There are several things you can do 
with a single dump or a collection of dumps.  

Compare Dump Features 
This is a very powerful feature that allows you to quickly analyze a 
situation and make a plan of action. 
 
Suppose a client sends you a collection of dumps, tells you that things 
are not hooked up properly and gives you a list of links that should be 
there. We apologize for all of our examples being about topology but 
that is what we know here at AMT! 
 
Rather than simply loading the dumps into your simulator and running 
your application, first scan the dumps into MDM and do a feature 
analysis. 
 
Right-click on a folder or multi-select specific dumps and select 
Compare features between dumps. 
 
The example below is a big comparison between 10 dumps. It is very 
easy to see what data is there and what data is missing. This allows 
you to quickly come up with an investigation plan. 
 

See graphic on next page 
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View The Dump Data 
MDM only handles the OIDs that are in a dump. It knows nothing about 
the data. But MDM works with the Network Ferret MIB Analysis tool. 
MA is essentially a MIB Browser on a dump file. Please see that 
documentation. 
 
Right-click on a MIB Dump and select Open File in MIB Analysis. 
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Extract Features From A Dump 
After setting a Features Filter by selecting Features in the right pane 
and then choosing Which dumps have this feature, you can right-
click on a text dump (not XML) and choose Extract features from file 
to extract those tables/variables from the MIB Dump.  Remember that 
you can always use Network Ferret – MIB Analysis to load the dump 
and browse all the data. 
 

 
 

Open the Dump File in a Text Editor 
Sometimes you want to browse the actual dump file. Although Network 
Ferret – MIB Analysis is much easier. 
 
First, select File->Set External Editor to set the editor on your 
machine. 
 
Second, optionally, select File->Set File Size Warning. Dump files 
can be very large and many times we have sat there and waited while 
our editor choked on an 80MB text file. Setting this value > 0 will 
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generate an “Are You Sure” dialog when you try to open a file larger 
than the warning value. 
 
Right-click on a dump and select Open file in editor. 

Various Copy Actions 
There are various Copy actions to make it easy to add some 
information to emails or documents. Things like the sysOID or device 
names, lists of IP addresses, etc. 

 

Which Project Use This Dump 
Generate Simulator Devices 

 
See the Simulator chapter for details. 
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7: Feature Actions 
The Feature hierarchy in the right pane of MDM reflects the Features 
defined in the XML definition file. There are several things you can do 
with a single feature or a collection of features. 

Which Dumps Have This Feature 
Suppose a client reports a bug in how your product handles table X.  
MDM allows you to quickly see which of your dumps has table X so 
you can start investigating/testing. 
 
Select one of more Features in the features pane, right-click and select 
Which dumps have this feature. Several things will happen: 
 
1 – A Feature Filter will be applied to the Dump Hierarchy on the left. 
2 – The text box to the right of the Expand Highlighted button will show 
how many dumps pass the filter. 
3 – Folders and dumps will be highlighted in the Dump Hierarchy. 
 
Optionally, hit the Expand Highlighted button to expand the tree to 
show every dump that passes the filter. 
 

 

Which Dumps DO NOT Have This Feature 
The inverse of the above filter. Sometimes it is interesting to see which 
dumps don’t have a common Feature such as the Interface Table. 
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Open MIB Analysis 
This is another integration with Network Ferret – MIB Analysis. Right-
click on a Feature and select Open MIB Analysis to this OID. 
 
This is useful when you need to refresh your memory regarding 
specific variable definitions/descriptions or enumeration values. 
 

 



 

 Network Ferret™ – MIB Dump Manager v18 23 

8: Notes 
If working in a team environment, it is useful to be able to attach notes 
to Folders or Dumps to indicate things like what trouble ticket is this 
dump associated with, or what test scenario is this folder associated 
with or maybe something special about the dump like the data in table 
X is not formatted to the standard in the MIB definition. 
 
Notes are NOT in the database. Notes are separate files in the file 
system.  Each Note is stored in the same folder as the dump. If your 
database gets corrupted and a rescan must be done, no Note data is 
lost because it is not there. 

Adding/Editing/Deleting A Note 
Adding/Editing a Note is easy.  Select a Folder or Dump in the Dump 
Hierarchy.  Select the Notes tab in the Features pane and start typing. 
 
There is no right-click menu but the standard CRTL-X, C and V are 
available. 

Who Has Notes 
From the main window menu select Filter->Dumps with notes to 
highlight all of the dumps with Notes. 
 
There is also a Filter for Notes containing a search phrase.  This 
search is case sensitive. 
 
The N column in the Dump Hierarchy will have an * for any folder or 
dump that has a note. 
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9: Simulator Integration 
AMT uses ireasoning as its SNMP Simulator. Since we do topology, 
we have no need for complex simulations with changing values. We 
have used Gambit Communications MIMIC in the past and it is also a 
fine product. 
 
The simulator integration with MDM involves scanning project files, 
generating project files and understanding what dumps are in which 
project. 

Setting the Simulator 
See the Definitions chapter to see how to tell MDM about your 
simulator location and files. 

Viewing Projects 
Select the Projects tab in the Features pane on the right. A tree view of 
the project hierarchy disk will be displayed. 

 
 

 
 

Double-click on a project and the Project tab will activate with the 
contents of the project file.  The file can be edited here. 
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Project <-> Dump Relationship 
Right-click on a Project and select Which dumps are in this project.  
The Dump Hierarchy on the left will have a project filter applied and all 
of the dumps in the project will be highlighted. In this case, it is clear 
that we gave the same name to the simulator project and the folders 
holding the dumps for the project. 
 

 
 
Conversely, in the Dump Hierarchy, right-click on a dump and select 
Which Projects use this dump. 
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